home
StrataCafe Forums
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 StrataCafe
 Strata Design 3D CX
 Startup problems
 New Topic  Reply to Topic
 Printer Friendly
Next Page
Author Previous Topic Topic Next Topic
Page: of 2

hieronymous
Infrequent Poster

Finland
31 Posts

Posted - 03/09/2016 :  02:49:39  Show Profile  Visit hieronymous's Homepage  Reply with Quote
Hello,

starting up Strata takes about 2 minutes
and is stuck at, see image -->

Image Insert:

12.18 KB

Then I reset the preferences
Quit Strata
Restarted the computer

But this is what I got in addition to the above:
cannot open my file as all items in the file menu are inaccessible
the startup window shows the option to "select" (and new project etc) but selecting "select" doesn't do anything, the startup window disappears

Image Insert:

53.16 KB

Opening a strata file from within the Finder results in a spinning beach ball for about 3 minutes and the file is very humble. But every mouse click from this moment onward results in delays, beach ball and waiting.


Tech info:

Image Insert:

38.48 KB

Any suggestions?


Thanks already
Jeroen

Edited by - hieronymous on 03/09/2016 03:01:26

MrChristopher
A Fountain of Information

USA
2220 Posts

Posted - 03/10/2016 :  00:23:05  Show Profile  Send MrChristopher an AOL message  Reply with Quote
Which version are you using?
Go to Top of Page

hieronymous
Infrequent Poster

Finland
31 Posts

Posted - 03/10/2016 :  01:32:51  Show Profile  Visit hieronymous's Homepage  Reply with Quote
Version 8.1.1
Winter 2015-2016 Release Active
Go to Top of Page

MrChristopher
A Fountain of Information

USA
2220 Posts

Posted - 03/10/2016 :  01:41:27  Show Profile  Send MrChristopher an AOL message  Reply with Quote
When you start, are you able to cancel the Initializing dialog? You should be able cancel it during the "Examining Libraries" part.
Go to Top of Page

hieronymous
Infrequent Poster

Finland
31 Posts

Posted - 03/10/2016 :  01:44:34  Show Profile  Visit hieronymous's Homepage  Reply with Quote
yes
the "cancel" button is greyed out though, but I can cancel it.

When i cancel it I can access the "File" menu and the "Open..." menu
Go to Top of Page

MrChristopher
A Fountain of Information

USA
2220 Posts

Posted - 03/10/2016 :  01:48:59  Show Profile  Send MrChristopher an AOL message  Reply with Quote
So it's working now?
Go to Top of Page

hieronymous
Infrequent Poster

Finland
31 Posts

Posted - 03/10/2016 :  01:49:30  Show Profile  Visit hieronymous's Homepage  Reply with Quote
In addition to my question, and as I have to move forward due to a deadline

I created a new bootable partition on my Mac
installed a fresh El Capitan + latest OS updates
Am using icloud to sign in to my computer (I never use this)
I can use Strata which is installed on the other partition
Strata opens faster, have to clock it still

When I follow Christopher's instruction I can open the File --> Open menu

When I do not cancel it and let Strata run it's course, and, I use the startup dialogue and try to use the "Open" button there I get an Alert


/Volumes/Hard Drive/Applications/strata 3D CX 8.app/Contents/Resources/Scripts/startup:lua:1255: Command not enabled.

...

Image Insert:

70.41 KB

Edited by - hieronymous on 03/10/2016 01:53:07
Go to Top of Page

hieronymous
Infrequent Poster

Finland
31 Posts

Posted - 03/10/2016 :  01:51:58  Show Profile  Visit hieronymous's Homepage  Reply with Quote
quote:
Originally posted by MrChristopher

So it's working now?



On this new partition, yes.
But do I need to cancel the "libraries" dialogue each time I start up?
What are the consequences?

I don't mind doing it as long as I don't get more problems down the road.

Thank Chris
Go to Top of Page

MrChristopher
A Fountain of Information

USA
2220 Posts

Posted - 03/10/2016 :  01:56:36  Show Profile  Send MrChristopher an AOL message  Reply with Quote
I've passed this onto the developers.

I actually cancel this initializing dialog all the time because Im impatient. :-)

What it will do is just not let you have access to the built-in libraries. But it shouldn't prevent you from using your own files.
Go to Top of Page

hieronymous
Infrequent Poster

Finland
31 Posts

Posted - 03/10/2016 :  01:58:43  Show Profile  Visit hieronymous's Homepage  Reply with Quote
quote:
Originally posted by MrChristopher

I've passed this onto the developers.

I actually cancel this initializing dialog all the time because Im impatient. :-)

What it will do is just not let you have access to the built-in libraries. But it shouldn't prevent you from using your own files.



Okay, I think I got that same character feature as well.
Still one question:
which are those built-in libraries?


And thanks for the fantastic help!!!
Go to Top of Page

MrChristopher
A Fountain of Information

USA
2220 Posts

Posted - 03/10/2016 :  02:07:51  Show Profile  Send MrChristopher an AOL message  Reply with Quote
The Resource palette has a bunch of textures, models and other presets which can be accessed quickly through the libraries button. Most of them I never use, but occasionally there are some animation scripts I will use. So for me canceling that scanning pass never causes a problem because I don't use the those built-in resources. Any resources you create as part of the file creation process are saved in the file itself and so you should always have access to those.

If you have used any of the built in resources in the past in a project, they will become integrated into the file and so canceling wouldn't affect those items.

My suspicion is that this might have something to do with OS X 10.11. I still am using 10.10.

Edited by - MrChristopher on 03/10/2016 10:39:50
Go to Top of Page

hieronymous
Infrequent Poster

Finland
31 Posts

Posted - 03/10/2016 :  02:13:36  Show Profile  Visit hieronymous's Homepage  Reply with Quote
Ok, clear.
I don't use the built in resources so I will be good in that regards.

I do live in Finland but originally am from The Netherlands. Finland is an interesting country to live in, if you once are in the vicinity let me know and I could show you around :-)

And thanks again for the help. I can move on now
Jeroen
Go to Top of Page

Kevco
Admin

454 Posts

Posted - 03/14/2016 :  20:36:59  Show Profile  Reply with Quote
Try re-running the Strata Updater on your CX 8.1.1 application. I suspect that something didn't update properly.

You might also want to restart the computer to clear things out of the system caches.
Go to Top of Page

hieronymous
Infrequent Poster

Finland
31 Posts

Posted - 03/15/2016 :  02:10:37  Show Profile  Visit hieronymous's Homepage  Reply with Quote
quote:
Originally posted by Kevco

Try re-running the Strata Updater on your CX 8.1.1 application. I suspect that something didn't update properly.

You might also want to restart the computer to clear things out of the system caches.



Thanks Kevin,

no effects, still 2+ minutes
Go to Top of Page

Kevco
Admin

454 Posts

Posted - 03/15/2016 :  12:10:31  Show Profile  Reply with Quote
Sorry, that suggestion was to try and help with the alert you reported.

Do you have a large set of custom libraries? If you do then those and the built in Resource Libraries can take longer to load.

Canceling the libraries scanning pass won't effect the use of the app, it will limit the resources available in the Resource Palette though.
Go to Top of Page

hieronymous
Infrequent Poster

Finland
31 Posts

Posted - 03/15/2016 :  12:13:59  Show Profile  Visit hieronymous's Homepage  Reply with Quote
quote:
Originally posted by Kevco

Sorry, that suggestion was to try and help with the alert you reported.

Do you have a large set of custom libraries? If you do then those and the built in Resource Libraries can take longer to load.

Canceling the libraries scanning pass won't effect the use of the app, it will limit the resources available in the Resource Palette though.




No, I have no custom libraries that I know of. All that came with the installation I got and then for my current model I have 14 textures.

Chris suggested the cancellation of the loading of the resource lib, I do that and it works just fine.

I can work with this delay as it doesn't seem to be something dramatic :-D

Thanks for the help!
J
Go to Top of Page

tbgriswold
Regularly Educational

USA
1436 Posts

Posted - 03/15/2016 :  12:27:58  Show Profile  Visit tbgriswold's Homepage  Reply with Quote
Possibly a bad file in the Resources Library?

Britt
Go to Top of Page

hieronymous
Infrequent Poster

Finland
31 Posts

Posted - 03/15/2016 :  12:48:25  Show Profile  Visit hieronymous's Homepage  Reply with Quote
quote:
Originally posted by tbgriswold

Possibly a bad file in the Resources Library?

Britt



could very well be, how to check for that?
J
Go to Top of Page

Kevco
Admin

454 Posts

Posted - 03/15/2016 :  12:55:16  Show Profile  Reply with Quote
You could try resetting preferences, repairing permissions (10.10.x and earlier) and restarting the computer. These steps have resolved some strange issues.

What is the speed of your hard drive? If a 5400rpm drive, then that is probably going cause the library loading to be slow.
Go to Top of Page

hieronymous
Infrequent Poster

Finland
31 Posts

Posted - 03/15/2016 :  13:04:58  Show Profile  Visit hieronymous's Homepage  Reply with Quote
quote:
Originally posted by Kevco

You could try resetting preferences, repairing permissions (10.10.x and earlier) and restarting the computer. These steps have resolved some strange issues.

What is the speed of your hard drive? If a 5400rpm drive, then that is probably going cause the library loading to be slow.


all done several times, even created a new HD partition with a clean OSX El Capitan install and only Strata running...

Will check the drive's speed.

But this afternoon I installed an SSD into my laptop which has also a new OSX. This SSD is now rendering 1 model so I have to wait for this to finished and then I restart Strata again and clock the lib loading speed.

But I got a deadline this night so perhaps I got the data tomorrow.

All in all, I can live with this. My only concerns was that this is not something that slowly degrades into a worse and worse performance.

:-D

Again thanks for the responses, feels good to have people read the questions and help.

Jeroen
Go to Top of Page

hieronymous
Infrequent Poster

Finland
31 Posts

Posted - 03/16/2016 :  04:19:01  Show Profile  Visit hieronymous's Homepage  Reply with Quote
Tested it on my SSD startup disk
After 5 minutes of still loading the libraries I pressed the cancel button as I have to get on with my work :-)

Then I updated to 8.1.1 with the latest updater. Now the loading of the libraries is less than 1 minute :-D

Something magical took place!

Thanks for the good work
J
Go to Top of Page
Page: of 2 Previous Topic Topic Next Topic  
Next Page
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
StrataCafe Forums © 2009 StrataCafe Go To Top Of Page
Snitz Forums 2000